Ayrshare - Issue publishing for some Instagram users – Incident details

Issue publishing for some Instagram users

Resolved
Operational
Started about 2 months agoLasted about 4 hours

Affected

Social Networks

Degraded performance from 2:00 PM to 6:08 PM

Instagram

Degraded performance from 2:00 PM to 6:08 PM

Updates
  • Update
    UTC
    Update

    Meta has now fixed the underlying issue and the URLs are being properly returned again.

  • Resolved
    UTC
    Resolved

    Our team has developed a workaround for this issue. We're able to bypass the problematic check media endpoint to allow Instagram publishing for affected users to succeed.

    However, posts using this workaround will not receive a post URL in the response. For now, you can still use the history API to "get post history for a platform" for the relevant post and receive the URL: https://www.ayrshare.com/docs/apis/history/history-platform

    Our team will work on a solution for the missing URLs and raise a bug report with Meta about the underlying issues.

  • Identified
    UTC
    Identified

    We're seeing a new issue from the Instagram API, where Meta is not returning a success response when we check status on media files via their API (as part of the publishing process). this is only affecting some users that use their Facebook account to control the related Instagram page. Our team is working on a workaround and we'll be deploying it soon.