Ayrshare - Temporary Platform Outage - Now Fixed – Incident details

Temporary Platform Outage - Now Fixed

Resolved
Major outage
Started 11 days agoLasted 35 minutes

Affected

Ayrshare API

Major outage from 2:40 PM to 3:15 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    As part of our missions to continuously improve the reliability of our product, the Ayrshare team has been working on a major platform upgrade with much more precise logging. This will be a huge step forward for the platform, but there was a misconfiguration in today's deployment which has now been fixed.

    We are deeply sorry for any inconvenience this caused. In addition to our automated testing for all code we write, we do full tests of the entire platform multiple times every day, however they take time to complete. In order to prevent future similar issues we're connecting the timing of the full regression testing to future production merges to prevent a possible recurrence of this issue.

    The improved logging is now live, and our team will continue our focus on improving the speed and reliability of the product for our customers.